The Altair Community is migrating to a new platform to provide a better experience for you. In preparation for the migration, the Altair Community is on read-only mode from October 28 - November 6, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here
Service is not running
Answers
-
BalazsBarany Administrator, Moderator, Employee-RapidMiner, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 955
Unicorn
Hi,
look into the configured Home directory for the server. There should be logs from the server startup.
Where did you install the server? Which path? Can you start it manually with the startup script?
Regards,
Balázs0 -
@BalazsBarany
Hello
I installed AI hub in default path ie C:\Users\[USERNAME]\rapidminer-ai-hub. I don't know about the "startup scripts". Just ran standalone.bat and it could be opened at localhost:8080But the windows service does not start even manually. (I performed the installation on another pc and the service starts while I get 404 error for the web based management panel). I think the problem is in log file.
Regards
A0 -
Also I got this error in studio:

0 -
BalazsBarany Administrator, Moderator, Employee-RapidMiner, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 955
Unicorn
That error in Studio is normal if the Server is not running correctly.
standalone.bat is the startup script. (It is called by the service, so if it doesn't run successfully, the service also won't.)
If you find the log file, search for 8080. As you got that error, the relevant messages should be near this one in the log.
Are you using a firewall on your machine? Another software that already uses port 8080? Which database type did you specify in the installation? Is it running correctly? Did the Server create tables in it?
Regards,
Balázs0 -
@BalazsBaranyThe only firewall is windows firewall. I checked with turning it offNo other software is using this port. I also checked with installation on 8888MS SQL server is used and the connection test successfully passed at installation (I checked with SQL 2019 and SQL2017). I can login to it from SQL management console.It seems there is no tables created in SQL server.
Also I got this error from RM Repository:
Regards
A0 -
BalazsBarany Administrator, Moderator, Employee-RapidMiner, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 955
Unicorn
If you want people to help you, you really need to everything they ask.
Did you find the logfile? Did you search for errors in it? It is really detailed, it says what it is doing and what is failing.
Regards,
Balázs0 -
@BalazsBarany
Yes, I find them which one do you need to post it for you?(because I can not understand them)
Regards
A0 -
@BalazsBarany
I find these texts in server log file:2020-12-04 17:44:58,065 WARNING [de.rapidanalytics.web.rest.HealthCheckService] (http-/0.0.0.0:8080-4) HealthCheck failed: Execution Backend is not available(http-/0.0.0.0:8080-4) There was an error during the processing of the request: The Job Service seems to not be available, please check your setup: org.jboss.resteasy.client.exception.ResteasyClientException: javax.management.InstanceNotFoundException: jboss.as:socket-binding-group=standard-sockets,socket-binding=http
I hope this helps
A0 -
BalazsBarany Administrator, Moderator, Employee-RapidMiner, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 955
Unicorn
Hi,
it should be at the beginning in the log file.
It writes a lot of diagnostic information and it is technical, but readable. Stuff like Error, Failed, Not available etc. are relevant here.
You can post the entire log file there, a developer might look into it. (I'm not one of those.) But you should check for errors yourself first.
Regards,
Balázs0

Learner II